Some syncs failing with "Missing corresponding dataset file for prefix: record_deletes.0"

Incident Report for Census

Resolved

No errors have been seen for over 30 minutes. We are declaring the incident resolved.
Posted Feb 05, 2025 - 23:30 UTC

Monitoring

The revert has deployed. We are monitoring to ensure that the errors subside.
Posted Feb 05, 2025 - 22:56 UTC

Identified

A recent code change introduced a bug resulting in some syncs failing with the message "Missing corresponding dataset file for prefix: record_deletes.0".

We have identified the problematic change, and a revert is in progress.
Posted Feb 05, 2025 - 22:38 UTC
This incident affected: Sync Engine.