Minor Delays in Census Syncs (US Region)

Incident Report for Census

Resolved

Delays have been resolved. Syncs are running normally again.
Posted Oct 29, 2025 - 03:09 UTC

Identified

We’ve identified the cause of the minor delays and implemented a fix. Sync performance returning back to normal. We’re monitoring to ensure continued stability.
Posted Oct 29, 2025 - 02:53 UTC

Investigating

We are currently investigating minor delays affecting some Census Sync job types in the US region. Most syncs are completing successfully, though some may take longer than usual.
Posted Oct 29, 2025 - 02:13 UTC
This incident affected: Sync Engine.