The error impacting some customer syncs has now been resolved and syncs are recovering.
The syncs impacted were runs with no new data changes to process. This happened due to a recent update that removed the part of our system that correctly handled "no change" scenarios. As a result, syncs without updates failed instead of completing successfully. Syncs with actual data changes were unaffected. We've rolled back the change, and all syncs are now running normally.
Posted Nov 12, 2025 - 18:30 UTC
Monitoring
The error impacting some customer syncs has now been resolved and syncs are recovering.
The syncs impacted were runs with no new data changes to process. This happened due to a recent update that removed the part of our system that correctly handled "no change" scenarios. As a result, syncs without updates failed instead of completing successfully. Syncs with actual data changes were unaffected. We've rolled back the change, and all syncs are now running normally.
Posted Nov 12, 2025 - 18:30 UTC
Identified
The issue has been identified and a fix is being implemented.