Sync failures and incorrect mappings when using "Sync All Properties"
Incident Report for Census
Resolved
We have completed our analysis of the outage and have determined that slightly less than 1% of all syncs using the "Sync All Properties" feature were affected by this issue. Those syncs have been configured to perform a "full sync" on their next run in order to resume successful execution. We have further determined that there were no syncs that had evidence of corrupted mappings, and that appropriate safeguards were in place to ensure that no syncs delivered incorrect data to their destinations.

All syncs that were paused for analysis at the beginning of this incident have been resumed.
Posted Jul 08, 2023 - 05:12 UTC
Update
We have nearly completed our impact assessment and preparing to unpause the affected syncs. For some affected syncs using Advanced Sync Engine, Census will force a full sync of the underlying dataset to fix any missing state tracking data.
Posted Jul 08, 2023 - 04:54 UTC
Identified
We have identified the root cause and are currently deploying a fix
Posted Jul 08, 2023 - 02:39 UTC
Investigating
We have identified an issue that can cause both sync failures and, in rare cases, corrupted mappings, when using the "Sync All Fields" behavior in Census. This can only occur after source schema changes, and "Sync All Fields" is not a default sync setting.

As a precaution, we are pausing all syncs using "Sync All Fields" until we can fully identify the issue.
Posted Jul 08, 2023 - 01:48 UTC
This incident affected: Sync Engine.