Unable to Authenticate
Incident Report for Census
Resolved
Incident is resolved. The underlying cause was an outage at Cloudflare impacting our authentication service. We'll be monitoring for any changes to this status.
Posted Oct 30, 2023 - 20:41 UTC
Investigating
We are currently investigating a problem folks are having trying to login to Census. It appears our Authentication provider is down.
Posted Oct 30, 2023 - 20:12 UTC
This incident affected: Census Sync Management UI.