Census UI not loading for some users
Incident Report for Census
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 03:37 UTC
Monitoring
The fix has been deployed. We are monitoring to make sure we are no longer seeing the issue.
Posted Mar 20, 2024 - 02:39 UTC
Identified
We have identified an issue causing pages for large workspaces to fail to render and 0.5% of other requests to fail. We are rolling out a fix.
Posted Mar 20, 2024 - 02:28 UTC
Investigating
We are currently investigating this issue.
Posted Mar 20, 2024 - 00:21 UTC
This incident affected: Census Sync Management UI.