Sync success rates have returned to expected levels. There is some delay in sync execution as we work through the backlog during the outage period. We are continuing to monitor
Posted Aug 23, 2024 - 19:04 UTC
Update
We have identified the likely root cause and are deploying a fix at this time
Posted Aug 23, 2024 - 18:48 UTC
Update
We have determined that the bug does not affect all syncs, nor does it cause records to be sent multiple times - this was a red herring.
A high percentage of syncs are still failing, but there is not a correctness issue, so we are reenabling the sync engine globally so that syncs that are not affected by the issue can return to operation.
Posted Aug 23, 2024 - 18:42 UTC
Update
We have identified an issue which could cause records to be synced multiple times to destinations. Since this can affect the correctness of syncs for certain destinations, we have paused all syncs proactively until the issue can be diagnosed and resolved. We are continuing to investigate and are in the act of rolling back to a previous version of the sync engine.
Posted Aug 23, 2024 - 17:58 UTC
Identified
Production sync execution has been paused while we investigate an issue