Sync Runs Failing with Undefined Column Error

Incident Report for Census

Resolved

This incident has been resolved.
Posted Jun 06, 2025 - 18:18 UTC

Monitoring

Some syncs started failing with the following error at 12:18pm (EST)

"ActiveRecord::StatementInvalid: PG::UndefinedColumn: ERROR: column sync_configurations.new_diff_timestamp_expression_id does not exist"

This was due to a brief issue during a schema update. The problem has been resolved, and we are monitoring.
Posted Jun 06, 2025 - 17:52 UTC
This incident affected: Sync Engine.