This incident has been resolved. Syncs have been running normally as of approximately 1:00pm EST, and the web has been running at normal latencies as of 2:00pm EST.
The issue was caused by an indexing change on our side that impacted our ability to run syncs reliably. Recovery was delayed because we needed to rebuild the previous indexes. To avoid any risk of data loss, we chose a safer recovery approach that allowed the system to remain temporarily degraded while repairs were being completed.
To restore syncs as quickly as possible, we prioritized sync execution and applied targeted fixes to improve performance. During this time, access to the UI was temporarily down.
Posted Jan 05, 2026 - 20:24 UTC
Monitoring
The web is now operating normally, along with Sync Runs. We are monitoring the system for overall health.
Posted Jan 05, 2026 - 19:05 UTC
Update
Syncs are now operational. Users may be experiencing issues loading Sync Configuration and Sync Run details on the web.
Posted Jan 05, 2026 - 18:34 UTC
Update
Syncs are currently not operational. Scheduled syncs should still be queuing up but they won't start running at this time. We will provide an update once workers come back up.
Posted Jan 05, 2026 - 16:47 UTC
Update
We are still seeing degraded performance and in some cases failing syncs. We are continuing efforts to mitigate as the system repairs.
Posted Jan 05, 2026 - 15:59 UTC
Update
We have identified and triaged the affected system and systems are coming back up now. Web is operational. We will see Sync delays as we scale back up.
Posted Jan 05, 2026 - 15:27 UTC
Identified
Census is currently having issues running Syncs and rendering the Website. Engineers have identified the issue and are remediating.
Posted Jan 05, 2026 - 15:17 UTC
This incident affected: Census Sync Management UI and Sync Engine.