Degraded UI performance

Incident Report for Fivetran Activations

Resolved

This incident has been resolved. A recent change prevented some UI jobs from being processed, causing some notifications to be delayed and dataset previews, sync configuration fields, and connection tests to fail to load successfully
Posted Sep 08, 2026 - 22:06 UTC

Monitoring

A fix has been implemented and we are monitoring results.
Posted Sep 08, 2026 - 21:02 UTC

Investigating

Some organizations are currently experiencing increased latency when running connection tests and loading source and destination objects within the sync editor.

Investigation is still ongoing.
Posted Sep 08, 2026 - 20:04 UTC
This incident affected: Census Sync Management UI.