Slowness and some requests failing

Incident Report for Census

Resolved

The outage was due to a db migration that took longer than was anticipated. Should be resolved now and will monitor for further slowness.
Posted Dec 17, 2024 - 21:21 UTC

Investigating

We are currently investigating this issue.
Posted Dec 17, 2024 - 21:18 UTC
This incident affected: Census Sync Management UI and Sync Engine.