Snowflake sources performing unnecessary full syncs
Incident Report for Census
Resolved
The advanced sync engine state has been repaired and all syncs are unpaused. If you have questions about a particular sync's state or history please reach out to your customer success team or support@getcensus.com.
Posted Oct 31, 2023 - 22:05 UTC
Update
We are unpausing all of the affected syncs and they will run on their normal schedules.

We are still investigating an issue with detection of deleted rows for "Mirror" syncs - delete propagation to destination systems may be delayed. We have a plan in place to restore delete propagation and we'll update here when in place.
Posted Oct 31, 2023 - 21:42 UTC
Update
We've finished repairing the Snowflake syncs, and have re-enabled the Snowflake syncs that we paused. We'll post more updates as we finish repairing Postgres and Redshift syncs.
Posted Oct 31, 2023 - 20:48 UTC
Update
We've expanded the pauses to Postgres and Redshift syncs. We're repairing data for all affected syncs and will provide further updates soon.
Posted Oct 31, 2023 - 20:01 UTC
Identified
We have administratively paused all affected Snowflake syncs while we repair the data in the advanced sync engine to ensure no more unnecessary full syncs occur
Posted Oct 31, 2023 - 18:49 UTC
Investigating
We are investigating an issue that has impacted Snowflake syncs. Syncs from Snowflake using the Advanced Sync Engine are sending records that have already been synced (acting like full syncs)
Posted Oct 31, 2023 - 18:18 UTC
This incident affected: Sync Engine.