Stuck syncs leading to decreased performance
Incident Report for Census
Resolved
We have mitigated the issue causing stuck syncs and syncs should run normally again. We have also identified potential improvements in the platform to prevent this in the future.
Posted Jul 27, 2023 - 22:41 UTC
Monitoring
We have reduced some internal timeouts on sync steps in an attempt to reduce the rate of stuck syncs, and we are continuing to monitor these changes to ensure syncs complete successfully.
Posted Jul 27, 2023 - 21:16 UTC
Identified
We are applying mitigations that should reduce the frequency of these failures. We have also identified the root cause for at least a subset of these issues.
Posted Jul 27, 2023 - 17:57 UTC
Investigating
We are investigating an issue with Census Reverse ETL syncs that are becoming "stuck" for minutes or hours at a time without making progress. This is affecting a small percentage of all syncs; we are working to determine the root cause and apply mitigations.
Posted Jul 27, 2023 - 16:27 UTC
This incident affected: Sync Engine.