Census Web Outage

Incident Report for Census

Resolved

The incident has been resolved. Issue determined to be caused due to a configuration change. Configuration change has been reverted.
Posted Feb 26, 2026 - 00:32 UTC

Investigating

We are currently investigating the issue.
Posted Feb 26, 2026 - 00:28 UTC
This incident affected: Census Sync Management UI.