Degraded Experience with Syncs and Models

Incident Report for Census

Resolved

Syncs and Model previews should be back to normal
Posted May 25, 2023 - 16:10 UTC

Investigating

We are current investigating failures in running syncs and model previews
Posted May 25, 2023 - 16:00 UTC
This incident affected: Sync Engine.