A fix has been implemented and we are monitoring the results.
Posted Jun 04, 2025 - 20:43 UTC
Update
A fix for this issue is currently being deployed and will be in place in the next 15-30 minutes
Posted Jun 04, 2025 - 20:24 UTC
Identified
The Census sync list UI is not loading for some customers. We have identified a faulty deployment and we are reverting it. The sync engine is not affected.
Posted Jun 04, 2025 - 20:11 UTC
This incident affected: Census Sync Management UI.