Census Outage
Incident Report for Census
Resolved
Our hosting provider has resolved their underlying issue. The Census Management UI is fully operational.
Posted Feb 24, 2022 - 17:56 UTC
Update
The Census Management UI is now back to available for most people. Our hosting provider is still recovering. We're continuing to monitor.
Posted Feb 24, 2022 - 17:17 UTC
Investigating
The hosting provider behind Census is undergoing issues. We're investigating the issue and its severity. The Census Management UI isn't available. Syncs are continuing to run.
Posted Feb 24, 2022 - 16:42 UTC
This incident affected: Census Sync Management UI.