UI slowdown across several areas
Incident Report for Census
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 22:47 UTC
Monitoring
A previous version of the job processor has been deployed and these tasks are once again being completed. We are continuing to monitor
Posted Mar 26, 2024 - 22:27 UTC
Identified
We have identified a faulty deploy and we are rolling it back
Posted Mar 26, 2024 - 22:04 UTC
Investigating
We have identified slowdowns in the Census UI associated with several areas:
* Model Previews
* Metadata Refreshes
* Sync Alerts

These are related to a slowdown in our job processing engine. At this time, our metrics do not show that sync performance or scheduling is affected but we are investigating these as well.
Posted Mar 26, 2024 - 21:53 UTC
This incident affected: Census Sync Management UI.