Census unable to send any emails

Incident Report for Census

Resolved

This incident has been resolved.
Posted Jul 15, 2025 - 18:44 UTC

Monitoring

We have updated the our configurations for sending emails and we are currently verifying the fix.
Posted Jul 15, 2025 - 18:31 UTC

Investigating

We have identified an incident that has caused Census to stop sending all emails. This includes emails related to sync alerts as well as password reset emails and verification emails for new account signups. We are working to remediate the issue. The Census UI and Sync Engine are not otherwise affected
Posted Jul 15, 2025 - 16:35 UTC
This incident affected: Census Sync Management UI.